Skip to main content

Manual

リトポロジー

リトポロジー (ver. 12)


概要

パターンにトポロジー線を生成することで、ポリゴン数の調整が可能になり、アニメーション用などに最適化されたエッジの連続性を持つ新しいメッシュを作成できます。


トポロジー

場所

3D/2D Window ツールバー ▶ トポロジー(U)

操作
  1. 上記「場所」項目に示されているメニューを確認します。
  2. トポロジーツールを選択すると、パターンは半透明表示に変わります。
    → パターンの上にマウスカーソルを置くと、パターンは元の色でハイライトされます。
    → 新しいトポロジーを作成できるのは、一度に1つのパターンだけです
  3. 強調表示されたパターンをクリックして、トポロジーポイントを追加します。
    → トポロジーは2Dおよび3D Window の両方で作成できますが、2D Window を使用することをお勧めします。


    面の生成
    → トポロジーラインの作成中、閉じたシェイプが生成されると、トポロジー面になります。
    → トポロジー面は、3点または4点/辺のシェイプ上でだけ作成されます。 
    → シェイプを閉じる前にトポロジの描画を停止するには(開いているシェイプを残す)、ダブルクリックして終了します。


    ポイント生成の取り消し 
    → キーボードの「Delete/Backspace」押してポイントを1つずつキャンセルします。
    → キーボードの「ESC、Ctl+Z」キーを押してすべてのポイントをキャンセルします
    。

    ループ状スライス
    → トポロジーツール使用中エッジ上で「Shift + Ctrl 左クリック」で連続したクアッドのループ状スライスが可能です。

その他の操作 (Ver.12以上)


トポロジー面の分割
→ 既存の青いトポロジー
面は、新しいトポロジーポイント・エッジを追加する事によって分割できます。
→ 切断面が多角形になると、4つ以上のサイドのトポロジー面がオレンジ色でハイライトされます。

トポロジー修正
場所

3D/2D Window ツールバー▶ トポロジー修正(Y)


操作
  1. 上記「場所」項目に示されているメニューを確認します。
  2. トポロジー修正ツールを選択すると、既存のトポロジが青でハイライトされます。
  3.  既存のトポロジーがあるパターンの上にマウスカーソルを置きます。
  4. トポロジーポイント、線、または面を選択して移動及び削除が可能です。

    点 / 線 / 面 複数選択 
    → Shift キーまたは Ctrl キーを押しながら、複数のトポロジー点 / 線をクリックし、選択に追加可能です。


    ポイントのドラッグ選択
    → Ctrl キーを押しながらドラッグして複数のトポロジーポイントを選択可能です。


    線のループ選択
    → トポロジー線をダブルクリックする事でループ選択可能です。

    ポイント、線、面の削除

    → Delete キーを押すか右クリックメニューから削除を選択することでポイント、線、面の削除が可能です。

    押し出し 
    → 線を選択し Shift + Ctrl を押しながらドラッグする事で線の押し出しが可能です。


    右クリックポップアップメニュー
    → ポイント、線、面または空白上で右クリックする事でポップアップメニューにアクセスできます。

    → 表示されるメニューは、操作の状況によって異なる場合があります。

  5. 削除  選択された要素を削除します。
    トポロジーのみ表示 (3D)

    3D window 上トポロジー以外のすべての要素を非表示にします。

    全て表示 3D window 上のすべての要素を表示します。
    併合  二つ以上のポイントを併合します。
    全体併合  すべてのトポロジーポイントを距離基準で併合します。
     トポロジーポイント間の距離を設定してApplyをクリックする事で併合可能です。「閉じる」をクリックしてメニューを閉じることが可能です。
    分割追加 (選択中のパターン)  選択したパターンのディビジョンを追加します。一度に1段階のディビジョンを追加します。
    分割追加 (全てのパターン)

     全てのトポロジー面に対してディビジョンを追加します。
     (空白上で右クリックする事でこのメニューが表示されます。)

    リメッシュ (複製)

    トポロジー適用 (複製)
    (ver. 2024.0)

     作成したトポロジー面基準の新しいメッシュを生成します。
      (パターンごとの適用)

    全パターンリメッシュ
    (複製)

    全パターントポロジー適用 (複製) (ver. 2024.0)

     すべてのパターンに対して作成したトポロジー面基準の新しいメッシュを生成します。

    リメッシュ (置き換え)

    トポロジー適用 (置換)
    (ver. 2024.0)

      既存のパターンを削除して作成したトポロジー面基準のメッシュを生成します。
      (パターンごとの適用)

    全パターンリメッシュ
    (置き換え)

    全パターントポロジー適用
    (置換) (ver. 2024.0)

     すべてのパターンを削除し、作成したトポロジー面基準のメッシュを生成します。

    表示/非表示

    → 作成したトポロジーの表示/非表示の切り替えはメインメニューから ▶ ディスプレイ ▶3D衣装 ▶ トポロジーを表示 より変更可能です。

    縫い合せ先へのトポロジーゴースト及びスナップ (Ver.11以上)
    → トポロジーポイントが縫い合せ先のパターンエッジ上に追加された場合、それらのポイントのゴーストが縫い合せ先に自動表示されます。
    →これらのゴーストトポロジーポイントを使用すると、縫い合せ先のパターンでのトポロジー作成が便利になります。

その他の操作 (Ver.12以上)


内部線分の縫い合せ先へのトポロジーゴースト表示及びスナップ
→トポロジーポイントが内部線分の縫い合せ先のパターンエッジ上に追加された場合、それらのポイントのゴーストが縫い合せ先に自動表示されます。

トポロジーポイントのドラッグ選択
→ 青色のトポロジーの外側をクリックしてドラッグし、複数のトポロジーポイントを一度に選択できます。
→ 「Shift」キーを押したまま、青いトポロジードラッグ選択して、トポロジーポイントを追加選択可能です。

トポロジーポイントをドラッグして選択解除
→ 「Ctrl」キーを押したまま選択中のトポロジーポイントをドラッグして選択を解除できます。

パッチトポロジー
場所

2D Window ツールバー ▶ パッチトポロジーツール 


操作 (Ver.11以上)
  1. 上記「場所」項目に示されているメニューを確認します。
  2. パッチトポロジーツールを選択すると、エッジのサブディビジョン数を調整できるポップアップボックスが表示されます。

    サブディビジョン

    エッジのサブディビジョン数を指定します。
    パッチスタイル
    (ver. 2024.1)

    グリッド

    グリッドは、より線形的な結果を得る従来のアルゴリズムです。 

    均一

    より自然な流れと少ない差異の結果を得る新アルゴリズムです。

    作成 パッチシェイプをクローズさせて「作成」をクリックする事でパッチがトポロジー面に変更されます。
    削除 全ての操作中のパッチを削除します。
  3. 2Dパターン上でパッチラインの作成 
    → クローズしたパッチが三角形または四角形の場合、内部のトポロジーはエッジに沿って指定されたサブディビジョン数に分割されます。
    → トポロジーパッチの作成中(パッチシェイプがクローズされる前)に、次のエッジのサブディビジョン数を変更することができます。
    → 完了したパッチエッジを選択し、サブディビジョン数を変更することにより、パッチを閉じた後(「作成」をクリックする前)にサブディビジョン数を変更することもできます。

その他の操作 (Ver.12以上)

パッチトポロジーの内部線分スナップ
→ パッチトポロジーのエッジはパターンアウトライン同様、内部線分でもスナップします。

パッチトポロジーの Convex カーブへのスナップ
→ パッチトポロジーのエッジは concaveカーブ同様 convexカーブにもスナップします。
→ エッジの曲率が極端すぎてパッチを作成できない場合は、カーブエッジに沿って1つまたは複数のカーブ点を「点追加/線分割」ツールで追加し、分割します。

トポロジー作成時のパッチの整合性の評価
→ トポロジパッチをクローズ後「作成」をクリックでパッチがオーバーラップするジオメトリになる場合、エラーウィンドウが表示されます。必要に応じて、パッチトポロジーツールに戻り、エッジ/頂点がオーバーラップしないように修正してください。
→ 作成されたパッチでジオメトリのオーバーラップがない場合は、トポロジーパッチが作成され、青色で表示されます。

※ パッチトポロジーのアルゴリズムが改善され、より効率的なクアッド形状が生成されます。(ver. 2024.0)

※ 四角で各辺に同じ数の点がある場合、グリッドパッチスタイルと均一パッチスタイルの結果は両方同じになります。(ver. 2024.1)


その他のお問い合わせ方法

リトポロジー (ver. 12) | Marvelous Designer